summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSkip Montanaro <skip@pobox.com>2001-08-21 04:23:21 (GMT)
committerSkip Montanaro <skip@pobox.com>2001-08-21 04:23:21 (GMT)
commite81f447800b1a62140729a00b4f4b56c4e7cc69e (patch)
tree83a44bb674723bb9161b635b84ac2f7b17a3034b /setup.py
parentd1ed15edb35f61d3ce321b53f3372bc227d150c8 (diff)
downloadcpython-e81f447800b1a62140729a00b4f4b56c4e7cc69e.zip
cpython-e81f447800b1a62140729a00b4f4b56c4e7cc69e.tar.gz
cpython-e81f447800b1a62140729a00b4f4b56c4e7cc69e.tar.bz2
This is supposed to help configure better sort out the various libdb
incarnations. It's probably not quite sufficient, but should be better than the status quo...
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0214b1d..b60b35e 100644
--- a/setup.py
+++ b/setup.py
@@ -389,7 +389,13 @@ class PyBuildExt(build_ext):
# BSD DB 3.x.)
dblib = []
- if self.compiler.find_library_file(lib_dirs, 'db'):
+ if self.compiler.find_library_file(lib_dirs, 'db-3.1'):
+ dblib = ['db-3.1']
+ elif self.compiler.find_library_file(lib_dirs, 'db2'):
+ dblib = ['db2']
+ elif self.compiler.find_library_file(lib_dirs, 'db1'):
+ dblib = ['db1']
+ elif self.compiler.find_library_file(lib_dirs, 'db'):
dblib = ['db']
db185_incs = find_file('db_185.h', inc_dirs,