diff options
author | Andrew M. Kuchling <amk@amk.ca> | 2001-05-21 20:29:27 (GMT) |
---|---|---|
committer | Andrew M. Kuchling <amk@amk.ca> | 2001-05-21 20:29:27 (GMT) |
commit | f52d27e52d289b99837b4555fb3f757f2c89f4ad (patch) | |
tree | 5c57f67adf2487375030b094f9be11d6d04f3a6d /setup.py | |
parent | c02bc3e81900cf46adb897e76d61f3983607d83d (diff) | |
download | cpython-f52d27e52d289b99837b4555fb3f757f2c89f4ad.zip cpython-f52d27e52d289b99837b4555fb3f757f2c89f4ad.tar.gz cpython-f52d27e52d289b99837b4555fb3f757f2c89f4ad.tar.bz2 |
Fix bug #232619: fix misleading warning on installing to lib-dynload
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 10 insertions, 1 deletions
@@ -12,6 +12,7 @@ from distutils import text_file from distutils.errors import * from distutils.core import Extension, setup from distutils.command.build_ext import build_ext +from distutils.command.install import install # This global variable is used to hold the list of modules to be disabled. disabled_module_list = [] @@ -598,10 +599,18 @@ class PyBuildExt(build_ext): # *** Uncomment these for TOGL extension only: # -lGL -lGLU -lXext -lXmu \ +class PyBuildInstall(install): + # Suppress the warning about installation into the lib_dynload + # directory, which is not in sys.path when running Python during + # installation: + def initialize_options (self): + install.initialize_options(self) + self.warn_dir=0 + def main(): setup(name = 'Python standard library', version = '%d.%d' % sys.version_info[:2], - cmdclass = {'build_ext':PyBuildExt}, + cmdclass = {'build_ext':PyBuildExt, 'install':PyBuildInstall}, # The struct module is defined here, because build_ext won't be # called unless there's at least one extension module defined. ext_modules=[Extension('struct', ['structmodule.c'])], |