summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2009-04-07 16:08:29 (GMT)
committerMatthias Klose <doko@ubuntu.com>2009-04-07 16:08:29 (GMT)
commit25c6cd2ae79828347c55cb047f47b5eaeb705d39 (patch)
tree23f0b25c7d643715952d9d8fdb9798725f2595a2 /setup.py
parent535336fa933600da1273f442028df62c08699848 (diff)
downloadcpython-25c6cd2ae79828347c55cb047f47b5eaeb705d39.zip
cpython-25c6cd2ae79828347c55cb047f47b5eaeb705d39.tar.gz
cpython-25c6cd2ae79828347c55cb047f47b5eaeb705d39.tar.bz2
Don't check for broken Berkley-DB versions on some platforms; the
test was required for the _bsddb3 extension, not necessary for the _dbm extension.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index b4bc3f7..3c228d5 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,6 @@ __version__ = "$Revision$"
import sys, os, imp, re, optparse
from glob import glob
-from platform import machine as platform_machine
from distutils import log
from distutils import sysconfig
@@ -671,13 +670,6 @@ class PyBuildExt(build_ext):
"""
if not (min_db_ver <= db_ver <= max_db_ver):
return False
- # Use this function to filter out known bad configurations.
- if (4, 6) == db_ver[:2]:
- # BerkeleyDB 4.6.x is not stable on many architectures.
- arch = platform_machine()
- if arch not in ('i386', 'i486', 'i586', 'i686',
- 'x86_64', 'ia64'):
- return False
return True
def gen_db_minor_ver_nums(major):