diff options
author | Miss Islington (bot) <31488909+miss-islington@users.noreply.github.com> | 2020-04-22 17:13:47 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-04-22 17:13:47 (GMT) |
commit | 4a6da0b63ba0fb811bfa3cacd69d22a9c0b24a4d (patch) | |
tree | 331178197c3a05dc003d08fe01ddfb4058360cdc /setup.py | |
parent | b07350901cac9197aef41855d8a4d56533636b91 (diff) | |
download | cpython-4a6da0b63ba0fb811bfa3cacd69d22a9c0b24a4d.zip cpython-4a6da0b63ba0fb811bfa3cacd69d22a9c0b24a4d.tar.gz cpython-4a6da0b63ba0fb811bfa3cacd69d22a9c0b24a4d.tar.bz2 |
bpo-38360: macOS: support alternate form of -isysroot flag (GH-16480)
It is possible to use either '-isysroot /some/path' (with a space) or
'-isysroot/some/path' (no space in between). Support both forms in
places where special handling of -isysroot is done, rather than just
the first form.
Co-authored-by: Ned Deily <nad@python.org>
(cherry picked from commit b310700976524b4b99ee319c947ca40468716fc9)
Co-authored-by: Joshua Root <jmr@macports.org>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -146,7 +146,7 @@ def macosx_sdk_root(): return MACOS_SDK_ROOT cflags = sysconfig.get_config_var('CFLAGS') - m = re.search(r'-isysroot\s+(\S+)', cflags) + m = re.search(r'-isysroot\s*(\S+)', cflags) if m is not None: MACOS_SDK_ROOT = m.group(1) else: |