diff options
author | Ned Deily <nad@acm.org> | 2013-08-02 06:51:27 (GMT) |
---|---|---|
committer | Ned Deily <nad@acm.org> | 2013-08-02 06:51:27 (GMT) |
commit | cd3d8fb8259cead872c5b313918c9a545ae97279 (patch) | |
tree | 981c431058200a95548621fbcfa26814abefff73 /setup.py | |
parent | bd143c3760afec6609155e94279cba7d07a743bd (diff) | |
download | cpython-cd3d8fb8259cead872c5b313918c9a545ae97279.zip cpython-cd3d8fb8259cead872c5b313918c9a545ae97279.tar.gz cpython-cd3d8fb8259cead872c5b313918c9a545ae97279.tar.bz2 |
Issue #18517: Move definition of "xxlimited" extension to detect_modules().
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 17 |
1 files changed, 9 insertions, 8 deletions
@@ -1525,6 +1525,15 @@ class PyBuildExt(build_ext): if '_tkinter' not in [e.name for e in self.extensions]: missing.append('_tkinter') +## # Uncomment these lines if you want to play with xxmodule.c +## ext = Extension('xx', ['xxmodule.c']) +## self.extensions.append(ext) + + if 'd' not in sys.abiflags: + ext = Extension('xxlimited', ['xxlimited.c'], + define_macros=[('Py_LIMITED_API', 1)]) + self.extensions.append(ext) + return missing def detect_tkinter_darwin(self, inc_dirs, lib_dirs): @@ -1722,14 +1731,6 @@ class PyBuildExt(build_ext): ) self.extensions.append(ext) -## # Uncomment these lines if you want to play with xxmodule.c -## ext = Extension('xx', ['xxmodule.c']) -## self.extensions.append(ext) - if 'd' not in sys.abiflags: - ext = Extension('xxlimited', ['xxlimited.c'], - define_macros=[('Py_LIMITED_API', 1)]) - self.extensions.append(ext) - # XXX handle these, but how to detect? # *** Uncomment and edit for PIL (TkImaging) extension only: # -DWITH_PIL -I../Extensions/Imaging/libImaging tkImaging.c \ |