diff options
author | Ned Deily <nad@acm.org> | 2014-06-25 20:42:22 (GMT) |
---|---|---|
committer | Ned Deily <nad@acm.org> | 2014-06-25 20:42:22 (GMT) |
commit | ce38f24af849694fe906b551184632717bf9ccf0 (patch) | |
tree | 4838379e900982e587ae317ebefcf312c4ae562d /setup.py | |
parent | 893df48682512382fd327045eb9a08fdc610b95e (diff) | |
parent | 04cdfa1147d5aadbee190b3aa2c4ccfd2d4a122d (diff) | |
download | cpython-ce38f24af849694fe906b551184632717bf9ccf0.zip cpython-ce38f24af849694fe906b551184632717bf9ccf0.tar.gz cpython-ce38f24af849694fe906b551184632717bf9ccf0.tar.bz2 |
Issue #21811: Anticipated fixes to 3.x and 2.7 for OS X 10.10 Yosemite.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -707,7 +707,9 @@ class PyBuildExt(build_ext): if host_platform == 'darwin': os_release = int(os.uname()[2].split('.')[0]) dep_target = sysconfig.get_config_var('MACOSX_DEPLOYMENT_TARGET') - if dep_target and dep_target.split('.') < ['10', '5']: + if (dep_target and + (tuple(int(n) for n in dep_target.split('.')[0:2]) + < (10, 5) ) ): os_release = 8 if os_release < 9: # MacOSX 10.4 has a broken readline. Don't try to build |