diff options
author | Ronald Oussoren <ronaldoussoren@mac.com> | 2006-06-04 14:24:59 (GMT) |
---|---|---|
committer | Ronald Oussoren <ronaldoussoren@mac.com> | 2006-06-04 14:24:59 (GMT) |
commit | fb2a169ce33885f6ea778f0942a80995d3c81b4f (patch) | |
tree | a06d11dcc656c7dea3567df71a445534bbc116fe /setup.py | |
parent | f70b14fb30cfc5d26fc260ee9af26b5ece58b9dd (diff) | |
download | cpython-fb2a169ce33885f6ea778f0942a80995d3c81b4f.zip cpython-fb2a169ce33885f6ea778f0942a80995d3c81b4f.tar.gz cpython-fb2a169ce33885f6ea778f0942a80995d3c81b4f.tar.bz2 |
Drop Mac wrappers for the WASTE library.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 23 |
1 files changed, 0 insertions, 23 deletions
@@ -1095,29 +1095,6 @@ class PyBuildExt(build_ext): extra_link_args=['-framework', 'QuickTime', '-framework', 'Carbon']) ) - # As there is no standardized place (yet) to put - # user-installed Mac libraries on OSX, we search for "waste" - # in parent directories of the Python source tree. You - # should put a symlink to your Waste installation in the - # same folder as your python source tree. Or modify the - # next few lines:-) - waste_incs = find_file("WASTE.h", [], - ['../'*n + 'waste/C_C++ Headers' for n in (0,1,2,3,4)]) - waste_libs = find_library_file(self.compiler, "WASTE", [], - ["../"*n + "waste/Static Libraries" for n in (0,1,2,3,4)]) - if waste_incs != None and waste_libs != None: - exts.append( Extension('waste', - ['waste/wastemodule.c'] + [ - os.path.join(srcdir, d) for d in - 'Mac/Wastemods/WEObjectHandlers.c', - 'Mac/Wastemods/WETabHooks.c', - 'Mac/Wastemods/WETabs.c' - ], - include_dirs = waste_incs + [os.path.join(srcdir, 'Mac/Wastemods')], - library_dirs = waste_libs, - libraries = ['WASTE'], - extra_link_args = ['-framework', 'Carbon'], - ) ) self.extensions.extend(exts) |