summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2020-12-05 04:26:59 (GMT)
committerGitHub <noreply@github.com>2020-12-05 04:26:59 (GMT)
commit06002b3f0d4570424feef37103c7e9b7d16bd63d (patch)
tree39bfd3bdc4e2fa66a4565301829e5b698528bec1 /setup.py
parentd1f07419c7560ed3ba52ba4f667f4eec9b5fe95d (diff)
downloadcpython-06002b3f0d4570424feef37103c7e9b7d16bd63d.zip
cpython-06002b3f0d4570424feef37103c7e9b7d16bd63d.tar.gz
cpython-06002b3f0d4570424feef37103c7e9b7d16bd63d.tar.bz2
[3.9] bpo-41116: Fix setup.py test for macOS Tcl/Tk frameworks (GH-23649) (GH-23650)
If no explicit macOS SDK was specified, setup.py should check for Tcl and TK frameworks in /Library/Frameworks; the previous commit inadvertently broke that test. (cherry picked from commit 29afab6c5f656f07ac85c9b2cf089631b2557a11) Co-authored-by: Ned Deily <nad@python.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bfe621d..bd5f736 100644
--- a/setup.py
+++ b/setup.py
@@ -177,10 +177,11 @@ def macosx_sdk_root():
m = re.search(r'-isysroot\s*(\S+)', cflags)
if m is not None:
MACOS_SDK_ROOT = m.group(1)
+ MACOS_SDK_SPECIFIED = MACOS_SDK_ROOT != '/'
else:
MACOS_SDK_ROOT = _osx_support._default_sysroot(
sysconfig.get_config_var('CC'))
- MACOS_SDK_SPECIFIED = MACOS_SDK_ROOT != '/'
+ MACOS_SDK_SPECIFIED = False
return MACOS_SDK_ROOT