summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2020-12-03 03:43:08 (GMT)
committerGitHub <noreply@github.com>2020-12-03 03:43:08 (GMT)
commit09a698b4743c669983d606595a1b2daeff6c3cf8 (patch)
tree33860516ff0a2d59d49ecdcf43ee7a0c04fab44c /setup.py
parent9b34f34aa929941576a69a6f7de77f1fb0b96ed6 (diff)
downloadcpython-09a698b4743c669983d606595a1b2daeff6c3cf8.zip
cpython-09a698b4743c669983d606595a1b2daeff6c3cf8.tar.gz
cpython-09a698b4743c669983d606595a1b2daeff6c3cf8.tar.bz2
bpo-42504: fix for MACOSX_DEPLOYMENT_TARGET=11 (GH-23556)
macOS releases numbering has changed as of macOS 11 Big Sur. Previously, major releases were of the form 10.x, 10.x+1, 10.x+2, etc; as of Big Sur, they are now x, x+1, etc, so, for example, 10.15, 10.15.1, ..., 10.15.7, 11, 11.0.1, 11.1, ..., 12, 12.1, etc. Allow Python to build with single-digit deployment target values. Patch provided by FX Coudert. (cherry picked from commit 5291639e611dc3f55a34666036f2c3424648ba50) Co-authored-by: FX Coudert <fxcoudert@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7432970..bfe621d 100644
--- a/setup.py
+++ b/setup.py
@@ -1012,7 +1012,7 @@ class PyBuildExt(build_ext):
os_release = int(os.uname()[2].split('.')[0])
dep_target = sysconfig.get_config_var('MACOSX_DEPLOYMENT_TARGET')
if (dep_target and
- (tuple(int(n) for n in dep_target.split('.')[0:2])
+ (tuple(int(n) for n in str(dep_target).split('.')[0:2])
< (10, 5) ) ):
os_release = 8
if os_release < 9: