diff options
author | Ronald Oussoren <ronaldoussoren@mac.com> | 2010-06-27 12:40:35 (GMT) |
---|---|---|
committer | Ronald Oussoren <ronaldoussoren@mac.com> | 2010-06-27 12:40:35 (GMT) |
commit | 0f2985c1c2861beec8e56f933ca207248e33c271 (patch) | |
tree | fa77f9dd05e16867ef2b918014739526626486c9 /setup.py | |
parent | 525201a08c82201d215ae2643d3b12d430bd9528 (diff) | |
download | cpython-0f2985c1c2861beec8e56f933ca207248e33c271.zip cpython-0f2985c1c2861beec8e56f933ca207248e33c271.tar.gz cpython-0f2985c1c2861beec8e56f933ca207248e33c271.tar.bz2 |
Merged revisions 82273 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k
................
r82273 | ronald.oussoren | 2010-06-27 14:37:46 +0200 (Sun, 27 Jun 2010) | 15 lines
Merged revisions 82272 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk
........
r82272 | ronald.oussoren | 2010-06-27 14:36:16 +0200 (Sun, 27 Jun 2010) | 8 lines
Two small fixes for the support for SDKs on MacOSX:
1) The code that checks if an path should be located in the SDK
explicitly excludes /usr/local. This fixes issue9046
2) The SDK variant for filtering "db_dirs_to_check" in setup.py
was not doing anything because of a missing assignment.
........
................
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -43,7 +43,7 @@ def is_macosx_sdk_path(path): """ Returns True if 'path' can be located in an OSX SDK """ - return path.startswith('/usr/') or path.startswith('/System/') + return (path.startswith('/usr/') and not path.startswith('/usr/local')) or path.startswith('/System/') def find_file(filename, std_dirs, paths): """Searches for the directory where a given file is located, @@ -868,6 +868,7 @@ class PyBuildExt(build_ext): else: if os.path.isdir(dn): tmp.append(dn) + db_dirs_to_check = tmp db_dirs_to_check = tmp |