diff options
author | Christian Heimes <christian@python.org> | 2019-04-09 16:40:12 (GMT) |
---|---|---|
committer | Miss Islington (bot) <31488909+miss-islington@users.noreply.github.com> | 2019-04-09 16:40:12 (GMT) |
commit | 8abc3f4f91e6b523c761c7a6fa2e3405019803a1 (patch) | |
tree | fc9112d1d6f40f2b5006c03132a57ccfd88ddc12 /setup.py | |
parent | bb4447897a5f141eecf42987a1191a3330c5d7ed (diff) | |
download | cpython-8abc3f4f91e6b523c761c7a6fa2e3405019803a1.zip cpython-8abc3f4f91e6b523c761c7a6fa2e3405019803a1.tar.gz cpython-8abc3f4f91e6b523c761c7a6fa2e3405019803a1.tar.bz2 |
bpo-36577: setup.py reports missing OpenSSL again (GH-12746)
[bpo-36146](https://bugs.python.org/issue36146) introduced another regression. In case of missing OpenSSL
libraries or headers, setup.py no longer reported _hashlib and _ssl to
be missing.
Signed-off-by: Christian Heimes <christian@python.org>
https://bugs.python.org/issue36577
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -2153,6 +2153,7 @@ class PyBuildExt(build_ext): openssl_libs = split_var('OPENSSL_LIBS', '-l') if not openssl_libs: # libssl and libcrypto not found + self.missing.extend(['_ssl', '_hashlib']) return None, None # Find OpenSSL includes @@ -2160,6 +2161,7 @@ class PyBuildExt(build_ext): 'openssl/ssl.h', self.inc_dirs, openssl_includes ) if ssl_incs is None: + self.missing.extend(['_ssl', '_hashlib']) return None, None # OpenSSL 1.0.2 uses Kerberos for KRB5 ciphers |