summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-06-27 12:37:46 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-06-27 12:37:46 (GMT)
commitdc969e591efa222d5fc29fb9aa39947e2339fa98 (patch)
tree0506ad152a696dbfbeab02244309adb2e4ec872a /setup.py
parent84594472692ae5bd77dd51a59c5dd55eaa7d50ef (diff)
downloadcpython-dc969e591efa222d5fc29fb9aa39947e2339fa98.zip
cpython-dc969e591efa222d5fc29fb9aa39947e2339fa98.tar.gz
cpython-dc969e591efa222d5fc29fb9aa39947e2339fa98.tar.bz2
Merged revisions 82272 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r82272 | ronald.oussoren | 2010-06-27 14:36:16 +0200 (Sun, 27 Jun 2010) | 8 lines Two small fixes for the support for SDKs on MacOSX: 1) The code that checks if an path should be located in the SDK explicitly excludes /usr/local. This fixes issue9046 2) The SDK variant for filtering "db_dirs_to_check" in setup.py was not doing anything because of a missing assignment. ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ab7909e..f97fbea 100644
--- a/setup.py
+++ b/setup.py
@@ -46,7 +46,7 @@ def is_macosx_sdk_path(path):
"""
Returns True if 'path' can be located in an OSX SDK
"""
- return path.startswith('/usr/') or path.startswith('/System/')
+ return (path.startswith('/usr/') and not path.startswith('/usr/local')) or path.startswith('/System/')
def find_file(filename, std_dirs, paths):
"""Searches for the directory where a given file is located,
@@ -862,6 +862,7 @@ class PyBuildExt(build_ext):
else:
if os.path.isdir(dn):
tmp.append(dn)
+ db_dirs_to_check = tmp
db_dirs_to_check = tmp