diff options
author | Xavier de Gaye <xdegaye@users.sourceforge.net> | 2016-12-10 15:45:53 (GMT) |
---|---|---|
committer | Xavier de Gaye <xdegaye@users.sourceforge.net> | 2016-12-10 15:45:53 (GMT) |
commit | 13f1c331a5dd5b4ff3b1e4c9e47d6d3ae75e0f8f (patch) | |
tree | ac92716b7fe1110c74dc88b51cd9ed681eac7ebe /setup.py | |
parent | 21799618ecf3a94c0a93ed56b0ad40af3035ea38 (diff) | |
download | cpython-13f1c331a5dd5b4ff3b1e4c9e47d6d3ae75e0f8f.zip cpython-13f1c331a5dd5b4ff3b1e4c9e47d6d3ae75e0f8f.tar.gz cpython-13f1c331a5dd5b4ff3b1e4c9e47d6d3ae75e0f8f.tar.bz2 |
Issue #28918: Fix the cross compilation of xxlimited when Python
has been built with Py_DEBUG defined.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -1630,7 +1630,7 @@ class PyBuildExt(build_ext): ## ext = Extension('xx', ['xxmodule.c']) ## self.extensions.append(ext) - if 'd' not in sys.abiflags: + if 'd' not in sysconfig.get_config_var('ABIFLAGS'): ext = Extension('xxlimited', ['xxlimited.c'], define_macros=[('Py_LIMITED_API', '0x03050000')]) self.extensions.append(ext) |