diff options
author | Ned Deily <nad@acm.org> | 2012-06-21 06:47:14 (GMT) |
---|---|---|
committer | Ned Deily <nad@acm.org> | 2012-06-21 06:47:14 (GMT) |
commit | 69192238ba5375c47ffa4b43726b117bcb31db9f (patch) | |
tree | 4dbd8c7f00839d2b09982b26c79d26d9b9f1d8f0 /setup.py | |
parent | fd8a838d582e3495004036bc82e3e6fee91fa0ba (diff) | |
download | cpython-69192238ba5375c47ffa4b43726b117bcb31db9f.zip cpython-69192238ba5375c47ffa4b43726b117bcb31db9f.tar.gz cpython-69192238ba5375c47ffa4b43726b117bcb31db9f.tar.bz2 |
Issue #14225: Fix Unicode support for curses (#12567) on OS X:
1. on OS X, there is no separate /usr/lib/libcursesw nor libpanelw
2. _XOPEN_SOURCE_EXTENDED must be enabled for _curses build
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 13 |
1 files changed, 13 insertions, 0 deletions
@@ -1185,6 +1185,18 @@ class PyBuildExt(build_ext): # Bug 1464056: If _curses.so links with ncursesw, # _curses_panel.so must link with panelw. panel_library = 'panelw' + if platform == 'darwin': + # On OS X, there is no separate /usr/lib/libncursesw nor + # libpanelw. If we are here, we found a locally-supplied + # version of libncursesw. There should be also be a + # libpanelw. _XOPEN_SOURCE defines are usually excluded + # for OS X but we need _XOPEN_SOURCE_EXTENDED here for + # ncurses wide char support + curses_defines.append(('_XOPEN_SOURCE_EXTENDED', '1')) + elif platform == 'darwin' and curses_library == 'ncurses': + # Building with the system-suppied combined libncurses/libpanel + curses_defines.append(('HAVE_NCURSESW', '1')) + curses_defines.append(('_XOPEN_SOURCE_EXTENDED', '1')) if curses_library.startswith('ncurses'): curses_libs = [curses_library] @@ -1213,6 +1225,7 @@ class PyBuildExt(build_ext): self.compiler.find_library_file(lib_dirs, panel_library)): exts.append( Extension('_curses_panel', ['_curses_panel.c'], include_dirs=curses_includes, + define_macros=curses_defines, libraries = [panel_library] + curses_libs) ) else: missing.append('_curses_panel') |