diff options
author | Antoine Pitrou <solipsis@pitrou.net> | 2010-12-04 18:36:03 (GMT) |
---|---|---|
committer | Antoine Pitrou <solipsis@pitrou.net> | 2010-12-04 18:36:03 (GMT) |
commit | 8c30a710e64223dbac70dae0a73ad4d8bd728786 (patch) | |
tree | ee32669259a48a5622db2c96323739d0c364db46 /setup.py | |
parent | 8c647cd73759601beba96e54720bf75b5d09ab19 (diff) | |
download | cpython-8c30a710e64223dbac70dae0a73ad4d8bd728786.zip cpython-8c30a710e64223dbac70dae0a73ad4d8bd728786.tar.gz cpython-8c30a710e64223dbac70dae0a73ad4d8bd728786.tar.bz2 |
Silence compile error
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -1579,9 +1579,10 @@ class PyBuildExt(build_ext): ## # Uncomment these lines if you want to play with xxmodule.c ## ext = Extension('xx', ['xxmodule.c']) ## self.extensions.append(ext) - ext = Extension('xxlimited', ['xxlimited.c'], - define_macros=[('Py_LIMITED_API', 1)]) - self.extensions.append(ext) + if 'd' not in sys.abiflags: + ext = Extension('xxlimited', ['xxlimited.c'], + define_macros=[('Py_LIMITED_API', 1)]) + self.extensions.append(ext) # XXX handle these, but how to detect? # *** Uncomment and edit for PIL (TkImaging) extension only: |