summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>2011-04-07 14:45:07 (GMT)
committerBarry Warsaw <barry@python.org>2011-04-07 14:45:07 (GMT)
commit9b5ac3efa64d72b54d4f1ab32a95c260b39ab98d (patch)
treeefeaf8ec7b73d47e21f4ba14f023927dca233feb /setup.py
parent12338ab10bf3c8b4099494dfd07da85df6c825e2 (diff)
parent88e194513e60853f7074d8f0fbca75d987a7a124 (diff)
downloadcpython-9b5ac3efa64d72b54d4f1ab32a95c260b39ab98d.zip
cpython-9b5ac3efa64d72b54d4f1ab32a95c260b39ab98d.tar.gz
cpython-9b5ac3efa64d72b54d4f1ab32a95c260b39ab98d.tar.bz2
Refinement by Stefan Krah (see issue 11715, msg133194) to exit early if the
dpkg-architecture command is not found on $PATH. This should fix the failures on FreeBSD and Solaris, which do not create the target file via I/O redirection if the command isn't found (unlike Linux and OS X which do).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3b48b93..1318bc2 100644
--- a/setup.py
+++ b/setup.py
@@ -373,6 +373,8 @@ class PyBuildExt(build_ext):
def add_multiarch_paths(self):
# Debian/Ubuntu multiarch support.
# https://wiki.ubuntu.com/MultiarchSpec
+ if not find_executable('dpkg-architecture'):
+ return
tmpfile = os.path.join(self.build_temp, 'multiarch')
if not os.path.exists(self.build_temp):
os.makedirs(self.build_temp)