summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAntoine Pitrou <solipsis@pitrou.net>2010-09-07 14:52:42 (GMT)
committerAntoine Pitrou <solipsis@pitrou.net>2010-09-07 14:52:42 (GMT)
commita300007c6e047bfdd7ab8f9bef35c0929d7dbbc8 (patch)
treeb82fed94f912ef39470f4a3b1e576d30daf8190b /setup.py
parent19651369e4f195633aa4be97ce8ccdb97289af5f (diff)
downloadcpython-a300007c6e047bfdd7ab8f9bef35c0929d7dbbc8.zip
cpython-a300007c6e047bfdd7ab8f9bef35c0929d7dbbc8.tar.gz
cpython-a300007c6e047bfdd7ab8f9bef35c0929d7dbbc8.tar.bz2
Issue #4026: Make the fcntl extension build under AIX.
Patch by Sébastien Sablé.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2b5d4cb..85cd605 100644
--- a/setup.py
+++ b/setup.py
@@ -499,7 +499,11 @@ class PyBuildExt(build_ext):
# supported...)
# fcntl(2) and ioctl(2)
- exts.append( Extension('fcntl', ['fcntlmodule.c']) )
+ libs = []
+ if (config_h_vars.get('FLOCK_NEEDS_LIBBSD', False)):
+ # May be necessary on AIX for flock function
+ libs = ['bsd']
+ exts.append( Extension('fcntl', ['fcntlmodule.c'], libraries=libs) )
# pwd(3)
exts.append( Extension('pwd', ['pwdmodule.c']) )
# grp(3)