summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBrett Cannon <brett@python.org>2013-07-12 15:30:32 (GMT)
committerBrett Cannon <brett@python.org>2013-07-12 15:30:32 (GMT)
commitae95b4f7a5344de372885fb25d8fadbb14c8fea4 (patch)
tree6b7441179c49c8b33507a1a9f5b4752e9a8f1e8a /setup.py
parenta79e4fb38d6e598be56944ead5753e65ad561bab (diff)
downloadcpython-ae95b4f7a5344de372885fb25d8fadbb14c8fea4.zip
cpython-ae95b4f7a5344de372885fb25d8fadbb14c8fea4.tar.gz
cpython-ae95b4f7a5344de372885fb25d8fadbb14c8fea4.tar.bz2
Issue #17845: Clarify the message setup.py prints upon successfully
building Python but having some optional module which didn't build. Patch by Yogesh Chaudhari.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 798220b..b2417c7 100644
--- a/setup.py
+++ b/setup.py
@@ -259,8 +259,9 @@ class PyBuildExt(build_ext):
if missing:
print()
- print("Python build finished, but the necessary bits to build "
- "these modules were not found:")
+ print("Python build finished successfully!")
+ print("The necessary bits to build these optional modules were not "
+ "found:")
print_three_column(missing)
print("To find the necessary bits, look in setup.py in"
" detect_modules() for the module's name.")