diff options
author | Martin Panter <vadmium+py@gmail.com> | 2016-02-03 05:19:44 (GMT) |
---|---|---|
committer | Martin Panter <vadmium+py@gmail.com> | 2016-02-03 05:19:44 (GMT) |
commit | c9deece272abe87865d91f3077fe4591e57303ad (patch) | |
tree | 0e37b52652488978ad93896991f7a94afbe2814c /setup.py | |
parent | a63897164eb1fb01bdc51fb8de0d6bc7eb791de9 (diff) | |
download | cpython-c9deece272abe87865d91f3077fe4591e57303ad.zip cpython-c9deece272abe87865d91f3077fe4591e57303ad.tar.gz cpython-c9deece272abe87865d91f3077fe4591e57303ad.tar.bz2 |
Issue #24421: Compile _math.c separately to avoid race condition
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 12 |
1 files changed, 8 insertions, 4 deletions
@@ -582,13 +582,17 @@ class PyBuildExt(build_ext): # array objects exts.append( Extension('array', ['arraymodule.c']) ) + + shared_math = 'Modules/_math.o' # complex math library functions - exts.append( Extension('cmath', ['cmathmodule.c', '_math.c'], - depends=['_math.h'], + exts.append( Extension('cmath', ['cmathmodule.c'], + extra_objects=[shared_math], + depends=['_math.h', shared_math], libraries=math_libs) ) # math library functions, e.g. sin() - exts.append( Extension('math', ['mathmodule.c', '_math.c'], - depends=['_math.h'], + exts.append( Extension('math', ['mathmodule.c'], + extra_objects=[shared_math], + depends=['_math.h', shared_math], libraries=math_libs) ) # time libraries: librt may be needed for clock_gettime() |