diff options
author | Ronald Oussoren <ronaldoussoren@mac.com> | 2010-10-20 13:10:12 (GMT) |
---|---|---|
committer | Ronald Oussoren <ronaldoussoren@mac.com> | 2010-10-20 13:10:12 (GMT) |
commit | f3500e119865b28c34ffacb9f582db49b9d70e9d (patch) | |
tree | 1c2fd75133dd44b40b135da9e67dea33ed7b377a /setup.py | |
parent | d0103292f052d3d5735d5b2d0a2307b02b75b8c3 (diff) | |
download | cpython-f3500e119865b28c34ffacb9f582db49b9d70e9d.zip cpython-f3500e119865b28c34ffacb9f582db49b9d70e9d.tar.gz cpython-f3500e119865b28c34ffacb9f582db49b9d70e9d.tar.bz2 |
Fix for issue #7473.
Without this patch you'll get link errors in some extensions
(in particular the _curses_panel) one when you try to build
a 3-way universal framework when you previously installed a
2-way universal framework using the python.org installer.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -400,7 +400,12 @@ class PyBuildExt(build_ext): for directory in reversed(options.dirs): add_dir_to_list(dir_list, directory) - if os.path.normpath(sys.prefix) != '/usr': + if os.path.normpath(sys.prefix) != '/usr' \ + and not sysconfig.get_config_var('PYTHONFRAMEWORK'): + # OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework + # (PYTHONFRAMEWORK is set) to avoid # linking problems when + # building a framework with different architectures than + # the one that is currently installed (issue #7473) add_dir_to_list(self.compiler.library_dirs, sysconfig.get_config_var("LIBDIR")) add_dir_to_list(self.compiler.include_dirs, |