summaryrefslogtreecommitdiffstats
path: root/Lib/test/libregrtest/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'Lib/test/libregrtest/setup.py')
-rw-r--r--Lib/test/libregrtest/setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/Lib/test/libregrtest/setup.py b/Lib/test/libregrtest/setup.py
index 5254e7f..ce81496 100644
--- a/Lib/test/libregrtest/setup.py
+++ b/Lib/test/libregrtest/setup.py
@@ -81,6 +81,17 @@ def setup_tests(ns):
setup_unraisable_hook()
+ if ns.timeout is not None:
+ # For a slow buildbot worker, increase SHORT_TIMEOUT and LONG_TIMEOUT
+ support.SHORT_TIMEOUT = max(support.SHORT_TIMEOUT, ns.timeout / 40)
+ support.LONG_TIMEOUT = max(support.LONG_TIMEOUT, ns.timeout / 4)
+
+ # If --timeout is short: reduce timeouts
+ support.LOOPBACK_TIMEOUT = min(support.LOOPBACK_TIMEOUT, ns.timeout)
+ support.INTERNET_TIMEOUT = min(support.INTERNET_TIMEOUT, ns.timeout)
+ support.SHORT_TIMEOUT = min(support.SHORT_TIMEOUT, ns.timeout)
+ support.LONG_TIMEOUT = min(support.LONG_TIMEOUT, ns.timeout)
+
def suppress_msvcrt_asserts(verbose):
try: