summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 99d99ae..5e56519 100644
--- a/configure.ac
+++ b/configure.ac
@@ -411,6 +411,7 @@ then
'') MACHDEP="unknown";;
esac
fi
+AC_MSG_RESULT("$MACHDEP")
AC_SUBST(_PYTHON_HOST_PLATFORM)
if test "$cross_compiling" = yes; then
@@ -4622,10 +4623,10 @@ AC_MSG_RESULT($LDVERSION)
# On Android and Cygwin the shared libraries must be linked with libpython.
AC_SUBST(LIBPYTHON)
-if test -z "$ANDROID_API_LEVEL" -o "$MACHDEP" != "cygwin"; then
- LIBPYTHON=''
-else
+if test -n "$ANDROID_API_LEVEL" -o "$MACHDEP" = "cygwin"; then
LIBPYTHON="-lpython${VERSION}${ABIFLAGS}"
+else
+ LIBPYTHON=''
fi
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.