summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0b28dda..57dca35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2858,7 +2858,17 @@ case "$ac_sys_system" in
AC_MSG_RESULT(yes)
],[
AC_MSG_RESULT(no)
- ]);;
+ ])
+dnl The AIX_BUILDDATE is obtained from the kernel fileset - bos.mp64
+# BUILD_GNU_TYPE + AIX_BUILDDATE are used to construct the platform_tag
+# of the AIX system used to build/package Python executable. This tag serves
+# as a baseline for bdist module packages
+ AC_MSG_CHECKING(for the system builddate)
+ AIX_BUILDDATE=$(lslpp -Lcq bos.mp64 | awk -F: '{ print $NF }')
+ AC_DEFINE_UNQUOTED([AIX_BUILDDATE], [$AIX_BUILDDATE],
+ [BUILD_GNU_TYPE + AIX_BUILDDATE are used to construct the PEP425 tag of the build system.])
+ AC_MSG_RESULT($AIX_BUILDDATE)
+ ;;
*) ;;
esac