summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8895818..d7699dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,12 @@ m4_ifdef(
[AX_C_FLOAT_WORDS_BIGENDIAN],
[],
[AC_MSG_ERROR([Please install autoconf-archive package and re-run autoreconf])]
-)
+)dnl
+m4_ifdef(
+ [PKG_PROG_PKG_CONFIG],
+ [],
+ [AC_MSG_ERROR([Please install pkgconf's m4 macro package and re-run autoreconf])]
+)dnl
AC_SUBST(BASECPPFLAGS)
if test "$srcdir" != . -a "$srcdir" != "$(pwd)"; then
@@ -6114,6 +6119,11 @@ $SHELL $srcdir/Modules/makesetup -c $srcdir/Modules/config.c.in \
Modules/Setup.local $srcdir/Modules/Setup
mv config.c Modules
+if test -z "$PKG_CONFIG"; then
+ echo "" >&AS_MESSAGE_FD
+ echo "pkg-config is missing. Some dependencies may not be detected correctly." >&AS_MESSAGE_FD
+fi
+
if test "$Py_OPT" = 'false' -a "$Py_DEBUG" != 'true'; then
echo "" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD