summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index 15e9a3a..f201748 100644
--- a/configure.in
+++ b/configure.in
@@ -1204,22 +1204,6 @@ LIBS="$LIBS $LIBM"
AC_REPLACE_FUNCS(hypot)
LIBS=$LIBS_SAVE
-# check for getopt
-AC_MSG_CHECKING(for genuine getopt)
-AC_CACHE_VAL(ac_cv_func_getopt,
-[AC_TRY_RUN([#include <stdio.h>
-extern int optind, opterr, getopt();
-extern char* optarg;
-int main() {
- char* av[] = { "testprog", "parameter", "-fFlag", NULL };
- opterr = 0;
- if (getopt(3, av, "f:") == 'f') { exit(1); }
- exit(0);
-}], ac_cv_func_getopt=yes, ac_cv_func_getopt=no, ac_cv_func_getopt=no)])dnl
-AC_MSG_RESULT($ac_cv_func_getopt)
-test $ac_cv_func_getopt = no && LIBOBJS="$LIBOBJS getopt.o"
-AC_SUBST(LIBOBJS)dnl
-
# check whether malloc(0) returns NULL or not
AC_MSG_CHECKING(what malloc(0) returns)
AC_CACHE_VAL(ac_cv_malloc_zero,