summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 79ace17..07f452d 100644
--- a/configure.in
+++ b/configure.in
@@ -11,11 +11,17 @@ AC_CONFIG_HEADER(pyconfig.h)
# This is for stuff that absolutely must end up in pyconfig.h.
# Please use pyport.h instead, if possible.
+AH_TOP([
+#ifndef Py_PYCONFIG_H
+#define Py_PYCONFIG_H
+])
AH_BOTTOM([
/* Define the macros needed if on a UnixWare 7.x system. */
#if defined(__USLC__) && defined(__SCO_VERSION__)
#define STRICT_SYSV_CURSES /* Don't use ncurses extensions */
#endif
+
+#endif /*Py_PYCONFIG_H*/
])
AC_SUBST(VERSION)