summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in46
1 files changed, 4 insertions, 42 deletions
diff --git a/configure.in b/configure.in
index d5f00b2..884f8bb 100644
--- a/configure.in
+++ b/configure.in
@@ -3615,57 +3615,19 @@ then
AC_MSG_RESULT($ac_cv_wchar_t_signed)
fi
-AC_MSG_CHECKING(what type to use for str)
-AC_ARG_WITH(wide-unicode,
- AS_HELP_STRING([--with-wide-unicode], [Use 4-byte Unicode characters (default is 2 bytes)]),
-[
-if test "$withval" != no
-then unicode_size="4"
-else unicode_size="2"
-fi
-],
-[
-case "$have_ucs4_tcl" in
- yes) unicode_size="4";;
- *) unicode_size="2" ;;
-esac
-])
-
-AH_TEMPLATE(Py_UNICODE_SIZE,
- [Define as the size of the unicode type.])
-case "$unicode_size" in
- 4)
- AC_DEFINE(Py_UNICODE_SIZE, 4)
- ABIFLAGS="${ABIFLAGS}u"
- ;;
- *) AC_DEFINE(Py_UNICODE_SIZE, 2) ;;
-esac
-
-AH_TEMPLATE(PY_UNICODE_TYPE,
- [Define as the integral type used for Unicode representation.])
-
# wchar_t is only usable if it maps to an unsigned type
-if test "$unicode_size" = "$ac_cv_sizeof_wchar_t" \
+if test "$ac_cv_sizeof_wchar_t" -ge 2 \
-a "$ac_cv_wchar_t_signed" = "no"
then
- PY_UNICODE_TYPE="wchar_t"
+ HAVE_USABLE_WCHAR_T="yes"
AC_DEFINE(HAVE_USABLE_WCHAR_T, 1,
[Define if you have a useable wchar_t type defined in wchar.h; useable
means wchar_t must be an unsigned type with at least 16 bits. (see
Include/unicodeobject.h).])
- AC_DEFINE(PY_UNICODE_TYPE,wchar_t)
-elif test "$ac_cv_sizeof_short" = "$unicode_size"
-then
- PY_UNICODE_TYPE="unsigned short"
- AC_DEFINE(PY_UNICODE_TYPE,unsigned short)
-elif test "$ac_cv_sizeof_long" = "$unicode_size"
-then
- PY_UNICODE_TYPE="unsigned long"
- AC_DEFINE(PY_UNICODE_TYPE,unsigned long)
else
- PY_UNICODE_TYPE="no type found"
+ HAVE_USABLE_WCHAR_T="no usable wchar_t found"
fi
-AC_MSG_RESULT($PY_UNICODE_TYPE)
+AC_MSG_RESULT($HAVE_USABLE_WCHAR_T)
# check for endianness
AC_C_BIGENDIAN