summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9ec081a..c8ba86b 100644
--- a/configure.in
+++ b/configure.in
@@ -1164,7 +1164,11 @@ then
# -u _PyMac_Error is needed to pull in the mac toolbox glue, which is
# not used by the core itself but which needs to be in the core so
# that dynamically loaded extension modules have access to it.
- LINKFORSHARED="$extra_undefs -framework System"
+ # -prebind causes the executable to assume dynamic libraries are at their
+ # preferred address, which speeds up startup. We specify it here
+ # in stead of in LDFLAGS because it does not seem to work for bundle
+ # plugins (as of OSX 10.2).
+ LINKFORSHARED="$extra_undefs -framework System -prebind"
if test "$enable_framework"
then
LINKFORSHARED="$LINKFORSHARED -framework Python"