summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 3bdb667..ee6b4bb 100644
--- a/configure.in
+++ b/configure.in
@@ -1133,10 +1133,13 @@ pthread_create (NULL, NULL, start_routine, NULL)], [
LIBS="$LIBS -lmpc"
LIBOBJS="$LIBOBJS thread.o"
USE_THREAD_MODULE=""])
- AC_CHECK_LIB(thread, thr_create, [AC_DEFINE(WITH_THREAD)
- LIBS="$LIBS -lthread"
- LIBOBJS="$LIBOBJS thread.o"
- USE_THREAD_MODULE=""])
+
+ if test $posix_threads != "yes"; then
+ AC_CHECK_LIB(thread, thr_create, [AC_DEFINE(WITH_THREAD)
+ LIBS="$LIBS -lthread"
+ LIBOBJS="$LIBOBJS thread.o"
+ USE_THREAD_MODULE=""])
+ fi
if test "$USE_THREAD_MODULE" != "#"
then