summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3c7db27..fbb7f02 100644
--- a/configure.in
+++ b/configure.in
@@ -120,7 +120,10 @@ AC_ARG_WITH(gcc, [--without-gcc never use gcc], [
ppc)
CC="mwcc -I$PWD/BeOS"
without_gcc=yes
- OPT="-DUSE_DL_EXPORT -O7 -opt schedule604"
+ case `uname -r` in
+ 4.0*) OPT="-DUSE_DL_EXPORT -O7 -opt schedule604 -export pragma" ;;
+ *) OPT="-DUSE_DL_EXPORT -O2 -proc 604e -export pragma" ;;
+ esac
CCSHARED=-UUSE_DL_EXPORT
LDFLAGS="$LDFLAGS -nodup"