summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5d60834..34113ca 100644
--- a/configure.in
+++ b/configure.in
@@ -306,6 +306,12 @@ then
fi
AC_MSG_CHECKING(for --with-thread)
+# Let --with-threads be an alias for --with-thread
+if test "${with_thread+set}" != set; then
+ if test "${with_threads+set}" = set; then
+ with_thread="$with_threads";
+ fi
+fi
AC_ARG_WITH(thread, [--with-thread[=DIRECTORY] make interpreter thread-safe], [
AC_MSG_RESULT($withval)
if test -d "$withval"