summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c13e848..eb57011 100644
--- a/configure.in
+++ b/configure.in
@@ -582,6 +582,12 @@ AC_MSG_RESULT($enable_toolbox_glue)
AC_SUBST(LIBTOOL_CRUFT)
case $ac_sys_system/$ac_sys_release in
+ Darwin/1.4*)
+ ns_undef_sym='_environ'
+ LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc -flat_namespace -U $ns_undef_sym"
+ LIBTOOL_CRUFT="$LIBTOOL_CRUFT $extra_frameworks"
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/Python'
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
Darwin/*)
ns_undef_sym='_environ'
LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc -U $ns_undef_sym"
@@ -599,7 +605,10 @@ then
# -F. is needed to allow linking to the framework while
# in the build location.
- LDFLAGS="$LDFLAGS -Wl,-F. -Wl,-U,$ns_undef_sym"
+ case $ac_sys_system/$ac_sys_release in
+ Darwin/1.4*)LDFLAGS="$LDFLAGS -Wl,-F. -Wl,-flat_namespace,-U,$ns_undef_sym";;
+ Darwin/*)LDFLAGS="$LDFLAGS -Wl,-F. -Wl,-U,$ns_undef_sym";;
+ esac
AC_DEFINE(WITH_NEXT_FRAMEWORK)
AC_MSG_RESULT(yes)
else
@@ -662,6 +671,15 @@ then
hp*|HP*) LDSHARED="ld -b";;
OSF*) LDSHARED="ld -shared -expect_unresolved \"*\"";;
DYNIX/ptx*) LDSHARED="ld -G";;
+ Darwin/1.4*)
+ LDSHARED='$(CC) $(LDFLAGS) -bundle'
+ if test "$enable_framework" ; then
+ # Link against the framework. All externals should be defined.
+ LDSHARED="$LDSHARED "'-framework $(PYTHONFRAMEWORK)'
+ else
+ # No framework. Ignore undefined symbols, assuming they come from Python
+ LDSHARED="$LDSHARED -flat_namespace -undefined suppress"
+ fi ;;
Darwin/*)
LDSHARED='$(CC) $(LDFLAGS) -bundle'
if test "$enable_framework" ; then