summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 34 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 608d6ae..2e7ebae 100644
--- a/configure.in
+++ b/configure.in
@@ -2274,11 +2274,11 @@ fi
AC_MSG_RESULT(MACHDEP_OBJS)
# checks for library functions
-AC_CHECK_FUNCS(alarm bind_textdomain_codeset chflags chown clock confstr \
+AC_CHECK_FUNCS(alarm bind_textdomain_codeset chown clock confstr \
ctermid execv fchmod fchown fork fpathconf ftime ftruncate \
gai_strerror getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getpwent getspnam getspent getsid getwd \
- kill killpg lchflags lchmod lchown lstat mkfifo mknod mktime \
+ kill killpg lchmod lchown lstat mkfifo mknod mktime \
mremap nice pathconf pause plock poll pthread_init \
putenv readlink realpath \
select setegid seteuid setgid \
@@ -2371,6 +2371,38 @@ AC_CHECK_LIB(c, inet_aton, [$ac_cv_prog_TRUE],
AC_CHECK_LIB(resolv, inet_aton)
)
+# On Tru64, chflags seems to be present, but calling it will
+# exit Python
+AC_MSG_CHECKING(for chflags)
+AC_TRY_RUN([
+#include <sys/stat.h>
+#include <unistd.h>
+int main(int argc, char*argv[])
+{
+ if(chflags(argv[0], 0) != 0)
+ return 1;
+ return 0;
+}
+],AC_DEFINE(HAVE_CHFLAGS, 1, Define to 1 if you have the `chflags' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
+AC_MSG_CHECKING(for lchflags)
+AC_TRY_RUN([
+#include <sys/stat.h>
+#include <unistd.h>
+int main(int argc, char*argv[])
+{
+ if(lchflags(argv[0], 0) != 0)
+ return 1;
+ return 0;
+}
+],AC_DEFINE(HAVE_LCHFLAGS, 1, Define to 1 if you have the `lchflags' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
dnl Check if system zlib has *Copy() functions
dnl
dnl On MacOSX the linker will search for dylibs on the entire linker path