summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 14 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index f9597a9..86b816d 100644
--- a/configure.in
+++ b/configure.in
@@ -813,14 +813,21 @@ AC_MSG_CHECKING(for --with-libdb)
AC_ARG_WITH(libdb,
[ --with(out)-libdb disable/enable bsddb module])
-# default is enabled
-if test -z "$with_libdb"
-then with_libdb="yes"
-fi
-# if we found db.h, enable, unless with_libdb is expressly set to "no"
-if test "$ac_cv_header_db_h" = "yes" -a "$with_libdb" != "no"
-then with_libdb="yes"
+# enabled by default, but db.h must be found
+if test "$ac_cv_header_db_h" = "yes"
+then
+ if test "$with_libdb" != "no"
+ then with_libdb="yes"
+ fi
+else
+ # make sure user knows why bsddb support wasn't enabled event
+ # though s/he requested it
+ if test "$with_libdb" = "yes"
+ then echo $ac_n "(requested, but db.h was not found) $ac_c"
+ fi
+ with_libdb="no"
fi
+
if test "$with_libdb" = "no"
then
USE_BSDDB_MODULE="#"