summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1950072..3892528 100644
--- a/configure.in
+++ b/configure.in
@@ -2898,6 +2898,8 @@ then
fi
# check where readline lives
+# save the value of LIBS so we don't actually link Python with readline
+LIBS_no_readline=$LIBS
AC_CHECK_LIB(readline, readline)
if test "$ac_cv_have_readline_readline" = no
then
@@ -2941,6 +2943,9 @@ then
[Define if you can turn off readline's signal handling.]), )
fi
+# End of readline checks: restore LIBS
+LIBS=$LIBS_no_readline
+
AC_MSG_CHECKING(for broken nice())
AC_CACHE_VAL(ac_cv_broken_nice, [
AC_TRY_RUN([