summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4869dd1..e461658 100644
--- a/configure.in
+++ b/configure.in
@@ -104,7 +104,7 @@ then
'') MACHDEP="unknown";;
esac
fi
-
+
# Some systems cannot stand _XOPEN_SOURCE being defined at all; they
# disable features if it is defined, without any means to access these
# features as extensions. For these systems, we skip the definition of
@@ -155,6 +155,18 @@ then
fi
AC_MSG_RESULT($MACHDEP)
+# And add extra plat-mac for darwin
+AC_SUBST(EXTRAPLATDIR)
+AC_MSG_CHECKING(EXTRAPLATDIR)
+if test -z "$EXTRAPLATDIR"
+then
+ case $MACHDEP in
+ darwin) EXTRAPLATDIR="\$(PLATMACDIRS)";;
+ *) EXTRAPLATDIR="";;
+ esac
+fi
+AC_MSG_RESULT($EXTRAPLATDIR)
+
# checks for alternative programs
AC_MSG_CHECKING(for --without-gcc)
AC_ARG_WITH(gcc,