summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 711856d..af1855e 100644
--- a/configure.in
+++ b/configure.in
@@ -3324,6 +3324,7 @@ int main(void) {
return 1;
}
sem_close(a);
+ sem_unlink("/autoconf");
return 0;
}
], ac_cv_posix_semaphores_enabled=yes,
@@ -3348,7 +3349,7 @@ AC_TRY_RUN([
#include <sys/stat.h>
int main(void){
- sem_t *a = sem_open("/autoconf", O_CREAT, S_IRUSR|S_IWUSR, 0);
+ sem_t *a = sem_open("/autocftw", O_CREAT, S_IRUSR|S_IWUSR, 0);
int count;
int res;
if(a==SEM_FAILED){
@@ -3358,6 +3359,7 @@ int main(void){
}
res = sem_getvalue(a, &count);
sem_close(a);
+ sem_unlink("/autocftw");
return res==-1 ? 1 : 0;
}
], ac_cv_broken_sem_getvalue=no,