summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in180
1 files changed, 101 insertions, 79 deletions
diff --git a/configure.in b/configure.in
index c818930..ae7431d 100644
--- a/configure.in
+++ b/configure.in
@@ -1,16 +1,12 @@
-dnl Process this file with autoconf 1.8 or later to make a configure script.
-AC_REVISION($Revision$)dnl
-AC_PREREQ(1.8)dnl
+dnl Process this file with autoconf 2.0 or later to make a configure script.
+AC_REVISION($Revision$)
+AC_PREREQ(2.0)
AC_INIT(Include/object.h)
-AC_CONFIG_HEADER(config.h)dnl
-# Don't suppress compiler output when --verbose is specified
-test -n "$verbose" &&
- ac_compile=`echo "$ac_compile" | sed "s|>/dev/null 2>&1||"`
-AC_VERBOSE(setting ac_compile to '$ac_compile')
+AC_CONFIG_HEADER(config.h)
# checks for alternative programs
AC_CHECKING(for --with(out)-gcc)
-AC_WITH(gcc, [
+AC_ARG_WITH(gcc, [--without-gcc never use gcc], [
case $withval in
no) withval=cc;;
yes) withval=gcc;;
@@ -19,7 +15,7 @@ AC_WITH(gcc, [
AC_PROG_CC
AC_PROG_RANLIB
AC_SUBST(AR)
-AC_PROGRAMS_CHECK(AR, ar aal, ar)
+AC_CHECK_PROGS(AR, ar aal, ar)
AC_SUBST(INSTALL)
# Install just never works :-(
if test -z "$INSTALL"
@@ -35,42 +31,41 @@ fi
AC_AIX
AC_ISC_POSIX
AC_MINIX
-dnl DYNIX test runs compile so must be last
-AC_DYNIX_SEQ
AC_CHECKING(for NeXT)
-AC_TEST_PROGRAM([
+AC_TRY_RUN([
#ifdef _NEXT_SOURCE
main() { exit(0); }
#endif
], AC_DEFINE(_POSIX_SOURCE))
# checks for header files
-AC_STDC_HEADERS
-AC_HAVE_HEADERS(dlfcn.h fcntl.h limits.h signal.h stdarg.h stddef.h stdlib.h thread.h unistd.h utime.h sys/audioio.h sys/param.h sys/select.h sys/time.h sys/times.h sys/un.h sys/utsname.h)
-AC_DIR_HEADER
+AC_HEADER_STDC
+AC_CHECK_HEADERS(dlfcn.h fcntl.h limits.h signal.h stdarg.h stddef.h stdlib.h thread.h unistd.h utime.h sys/audioio.h sys/param.h sys/select.h sys/time.h sys/times.h sys/un.h sys/utsname.h)
+AC_HEADER_DIRENT
# checks for typedefs
AC_CHECKING(for clock_t in time.h)
-AC_HEADER_EGREP(clock_t, time.h, , AC_DEFINE(clock_t, long))
-AC_MODE_T
-AC_OFF_T
-AC_PID_T
-AC_RETSIGTYPE
-AC_SIZE_T
-AC_UID_T
+AC_EGREP_HEADER(clock_t, time.h, , AC_DEFINE(clock_t, long))
+AC_TYPE_MODE_T
+AC_TYPE_OFF_T
+AC_TYPE_PID_T
+AC_TYPE_SIGNAL
+AC_TYPE_SIZE_T
+AC_TYPE_UID_T
# Set name for machine-dependent library files
AC_SUBST(MACHDEP)
+AC_MSG_CHECKING(MACHDEP)
if test -z "$MACHDEP"
then
- ac_system=`uname -s | tr '[[A-Z]]' '[[a-z]]'`
- ac_release=`uname -r | sed 's/\..*//'`
- MACHDEP="$ac_system$ac_release"
+ ac_sys_system=`uname -s | tr -d ' ' | tr '[[A-Z]]' '[[a-z]]'`
+ ac_sys_release=`uname -r | tr -d ' ' | sed 's/\..*//'`
+ MACHDEP="$ac_sys_system$ac_sys_release"
case MACHDEP in
'') MACHDEP=unknown;;
esac
- AC_VERBOSE(setting MACHDEP to '$MACHDEP')
fi
+AC_MSG_RESULT($MACHDEP)
# Set info about shared libraries.
# XXX This should try things out instead of testing uname!
@@ -78,68 +73,69 @@ AC_SUBST(SO)
AC_SUBST(LDSHARED)
AC_SUBST(CCSHARED)
AC_SUBST(LINKFORSHARED)
-ac_system=`uname -s`
-ac_release=`uname -r`
+ac_sys_system=`uname -s`
+ac_sys_release=`uname -r`
# SO is the extension of shared libraries `(including the dot!)
# -- usually .so, .sl on HP-UX
+AC_MSG_CHECKING(SO)
if test -z "$SO"
then
- case $ac_system in
+ case $ac_sys_system in
hp*|HP*) SO=.sl;;
*) SO=.so;;
esac
- AC_VERBOSE(setting SO to '$SO')
fi
+AC_MSG_RESULT($SO)
# LDSHARED is the ld *command* used to create shared library
# -- "ld" on SunOS 4.x.x, "ld -G" on SunOS 5.x, "ld -shared" on IRIX 5
+AC_MSG_CHECKING(LDSHARED)
if test -z "$LDSHARED"
then
- case $ac_system/$ac_release in
+ case $ac_sys_system/$ac_sys_release in
IRIX*) LDSHARED="ld -shared";;
SunOS/4*) LDSHARED="ld";;
SunOS/5*) LDSHARED="ld -G";;
hp*|HP*) LDSHARED="ld -b";;
*) LDSHARED="ld";;
esac
- AC_VERBOSE(setting LDSHARED= to '$LDSHARED')
fi
+AC_MSG_RESULT($LDSHARED)
# CCSHARED are the C *flags* used to create objects to go into a shared
# library -- this is only needed for HP-UX
+AC_MSG_CHECKING(CCSHARED)
if test -z "$CCSHARED"
then
- case $ac_system in
+ case $ac_sys_system in
hp*|HP*) CCSHARED="+z";;
esac
- AC_VERBOSE(setting CCSHARED= to '$CCSHARED')
fi
+AC_MSG_RESULT($CCSHARED)
# LINKFORSHARED are the flags passed to the $(CC) command that links
# the python executable -- this is only needed for HP-UX
+AC_MSG_CHECKING(LINKFORSHARED)
if test -z "$LINKFORSHARED"
then
- case $ac_system in
+ case $ac_sys_system in
hp*|HP*) LINKFORSHARED="-Wl,-E";;
esac
- AC_VERBOSE(setting LINKFORSHARED to '$LINKFORSHARED')
fi
+AC_MSG_RESULT($LINKFORSHARED)
# checks for libraries
-AC_HAVE_LIBRARY(dl) # Dynamic linking for SunOS/Solaris (and SYSV?)
-AC_HAVE_LIBRARY(dld) # Dynamic linking for HP-UX
-
-AC_CHECKING(for --with-svr4)
-AC_WITH(svr4, [
-AC_HAVE_LIBRARY(socket)
-AC_HAVE_LIBRARY(inet)
-AC_HAVE_LIBRARY(nsl)
-])
+AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
+AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
+AC_CHECK_LIB(sun, getpwnam) # NIS (== YP) interface for IRIX 4
+AC_CHECK_LIB(socket, socket, [LIBS=-lsocket -linet -lnsl], [], [-linet -lnsl])
AC_CHECKING(for --with-readline)
-AC_WITH(readline, [AC_DEFINE(WITH_READLINE)
+AC_ARG_WITH(readline, [--with-readline=DIRECTORY GNU readline], [
+AC_DEFINE(WITH_READLINE)
if test ! -d "$withval"
then AC_ERROR(proper usage is --with-readline=DIRECTORY)
fi
termcap=
-AC_HAVE_LIBRARY(termcap, [termcap=termcap], [AC_HAVE_LIBRARY(termlib, [termcap=termlib])])
+AC_CHECK_LIB(termcap, tgetent, [termcap=termcap], [
+AC_CHECK_LIB(termlib, tgetent, [termcap=termlib])])
if test ! -z "$termcap"
then LIBS="$LIBS $withval/libreadline.a"
# Avoid possible conflict between shared libraries termcap and gl
@@ -152,18 +148,18 @@ else AC_ERROR(no working termcap/termlib, do not use --with-readline)
fi])
AC_CHECKING(for --with-thread)
-AC_WITH(thread, [
+AC_ARG_WITH(thread, [--with-thread[=DIRECTORY] make interpreter thread-safe], [
if test -d "$withval"
then LIBS="$LIBS -L$withval"
fi
-AC_HAVE_LIBRARY(pthreads, [AC_DEFINE(WITH_THREAD)
+AC_CHECK_LIB(pthreads, pthread_create, [AC_DEFINE(WITH_THREAD)
AC_DEFINE(_POSIX_THREADS)
LIBS="$LIBS -lpthreads"
LIBOBJS="$LIBOBJS thread.o"])
-AC_HAVE_LIBRARY(mpc, [AC_DEFINE(WITH_THREAD)
+AC_CHECK_LIB(mpc, usconfig, [AC_DEFINE(WITH_THREAD)
LIBS="$LIBS -lmpc"
LIBOBJS="$LIBOBJS thread.o"])
-AC_HAVE_LIBRARY(thread, [AC_DEFINE(WITH_THREAD)
+AC_CHECK_LIB(thread, thr_create, [AC_DEFINE(WITH_THREAD)
LIBS="$LIBS -lthread"
LIBOBJS="$LIBOBJS thread.o"])
])
@@ -173,7 +169,8 @@ AC_SUBST(DLINCLDIR)
DLINCLDIR=/
AC_CHECKING(for --with-sgi-dl)
-AC_WITH(sgi-dl, [AC_DEFINE(WITH_SGI_DL)
+AC_ARG_WITH(sgi-dl, [--with-sgi-dl=DIRECTORY IRIX 4 dynamic linking], [
+AC_DEFINE(WITH_SGI_DL)
dldir=$withval
if test -d "$dldir"
then LIBS="$LIBS -L$dldir"
@@ -183,7 +180,8 @@ DLINCLDIR=${dldir}
LIBS="$LIBS -ldl -lmld"])
AC_CHECKING(for --with-dl-dld)
-AC_WITH(dl-dld, [AC_DEFINE(WITH_DL_DLD)
+AC_ARG_WITH(dl-dld, [--with-dl-dld=DL_DIR,DLD_DIR GNU dynamic linking], [
+AC_DEFINE(WITH_DL_DLD)
dldir=`echo "$withval" | sed 's/,.*//'`
dlddir=`echo "$withval" | sed 's/.*,//'`
if test -d "$dldir" -a -d "$dlddir"
@@ -194,17 +192,29 @@ DLINCLDIR=${dldir}
LIBS="$LIBS -ldl -ldld"])
# checks for library functions
-AC_HAVE_FUNCS(chown clock dlopen ftime gettimeofday getpeername getpgrp getpid getwd link lstat nice readlink select setgid setuid setsid setpgid setpgrp setvbuf siginterrupt symlink tcgetpgrp tcsetpgrp times uname waitpid)
+AC_CHECK_FUNCS(chown clock dlopen ftime ftruncate gethostname_r gettimeofday getpeername getpgrp getpid getwd link lstat nice readlink select setgid setuid setsid setpgid setpgrp setvbuf siginterrupt symlink tcgetpgrp tcsetpgrp times truncate uname waitpid)
AC_REPLACE_FUNCS(dup2 getcwd strerror memmove)
-AC_FUNC_CHECK(getpgrp, AC_COMPILE_CHECK([argument to getpgrp], [#include <unistd.h>], [getpgrp(0);], AC_DEFINE(GETPGRP_HAVE_ARG)))
-AC_FUNC_CHECK(setpgrp, AC_COMPILE_CHECK([arguments to setpgrp], [#include <unistd.h>], [setpgrp(0,0);], AC_DEFINE(SETPGRP_HAVE_ARG)))
+AC_CHECK_FUNC(getpgrp, AC_TRY_COMPILE([#include <unistd.h>], [getpgrp(0);], AC_DEFINE(GETPGRP_HAVE_ARG)))
+AC_CHECK_FUNC(setpgrp, AC_TRY_COMPILE([#include <unistd.h>], [setpgrp(0,0);], AC_DEFINE(SETPGRP_HAVE_ARG)))
+AC_CHECK_FUNC(gettimeofday, AC_TRY_COMPILE([#include <sys/time.h>], [gettimeofday((struct timeval*)0,(struct timezone*)0);], ,AC_DEFINE(GETTIMEOFDAY_NO_TZ)))
# checks for structures
-AC_TIME_WITH_SYS_TIME
+AC_HEADER_TIME
AC_STRUCT_TM
-AC_TIMEZONE
-AC_COMPILE_CHECK([whether we have altzone], [#include <time.h>], [return altzone;], AC_DEFINE(HAVE_ALTZONE))
-AC_COMPILE_CHECK([whether sys/select.h and sys/time.h may both be included], [
+AC_STRUCT_TIMEZONE
+
+AC_MSG_CHECKING(for time.h that defines altzone)
+AC_CACHE_VAL(ac_cv_header_time_altzone,
+[AC_TRY_COMPILE([#include <time.h>], [return altzone;],
+ ac_cv_header_time_altzone=yes,
+ ac_cv_header_time_altzone=no)])
+AC_MSG_RESULT($ac_cv_header_time_altzone)
+if test $ac_cv_header_time_altzone = yes; then
+ AC_DEFINE(HAVE_ALTZONE)
+fi
+
+AC_CHECKING(whether sys/select.h and sys/time.h may both be included)
+AC_TRY_COMPILE([
#include <sys/types.h>
#include <sys/select.h>
#include <sys/time.h>
@@ -212,32 +222,34 @@ AC_COMPILE_CHECK([whether sys/select.h and sys/time.h may both be included], [
# checks for compiler characteristics
-AC_CHAR_UNSIGNED
+AC_C_CHAR_UNSIGNED
-AC_CONST
+AC_C_CONST
-AC_COMPILE_CHECK([lack of working volatile],[],[volatile int x; x = 0;],,AC_DEFINE(volatile,))
+AC_CHECKING(for working volatile)
+AC_TRY_COMPILE([],[volatile int x; x = 0;],,AC_DEFINE(volatile, []))
-AC_COMPILE_CHECK([lack of working signed char], [], [signed char c;],,AC_DEFINE(signed, []))
+AC_CHECKING(for working signed char)
+AC_TRY_COMPILE([], [signed char c;],,AC_DEFINE(signed, []))
AC_CHECKING(for prototypes)
-AC_TEST_PROGRAM([
-int foo(int x) { return 0; }
-int main() { return foo(10); }
-], AC_DEFINE(HAVE_PROTOTYPES) have_prototypes=1)
+AC_TRY_COMPILE([int foo(int x) { return 0; }], [return foo(10);],
+AC_DEFINE(HAVE_PROTOTYPES) have_prototypes=yes)
AC_CHECKING(for variable length prototypes and stdarg.h)
-AC_TEST_PROGRAM([
+AC_TRY_COMPILE([
#include <stdarg.h>
int foo(int x, ...) { return 0; }
-int main() { return foo(10, 11, 12); }
-], AC_DEFINE(HAVE_STDARG_PROTOTYPES) have_prototypes=1)
+], [return foo(10, 11, 12);],
+AC_DEFINE(HAVE_STDARG_PROTOTYPES))
+
if test "$have_prototypes"; then
-AC_COMPILE_CHECK(["bad exec* prototypes"], [#include <unistd.h>], [char **t;execve("@",t,t);], , AC_DEFINE(BAD_EXEC_PROTOTYPES))
+AC_CHECKING(for bad exec* prototypes)
+AC_TRY_COMPILE([#include <unistd.h>], [char **t;execve("@",t,t);], , AC_DEFINE(BAD_EXEC_PROTOTYPES))
fi
AC_CHECKING(for bad static forward)
-AC_TEST_PROGRAM([
+AC_TRY_RUN([
struct s { int a; int b; };
static struct s foo;
int foobar() {
@@ -251,24 +263,34 @@ main() {
}
], , AC_DEFINE(BAD_STATIC_FORWARD))
+AC_CHECKING(whether va_list is an array)
+AC_TRY_COMPILE([
+#ifdef HAVE_STDARG_PROTOTYPES
+#include <stdarg.h>
+#else
+#include <varargs.h>
+#endif
+], [va_list list1, list2; list1 = list2;], , AC_DEFINE(VA_LIST_IS_ARRAY))
+
# checks for system services
# (none yet)
-# other checks for UNIX variants
-AC_IRIX_SUN
-AC_XENIX_DIR
+# Linux requires this for correct f.p. operations
+AC_CHECK_LIB(ieee, __fpu_control)
# check for --with-libm=...
AC_SUBST(LIBM)
LIBM=-lm
-AC_WITH(libm, [if test "$withval" != yes
+AC_ARG_WITH(libm, [--with-libm=STRING math library], [
+if test "$withval" != yes
then LIBM=$withval
else AC_ERROR(proper usage is --with-libm=STRING)
fi])
# check for --with-libc=...
AC_SUBST(LIBC)
-AC_WITH(libc, [if test "$withval" != yes
+AC_ARG_WITH(libc, [--with-libc=STRING C library], [
+if test "$withval" != yes
then LIBC=$withval
else AC_ERROR(proper usage is --with-libc=STRING)
fi])