diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -141,7 +141,10 @@ class PyBuildExt(build_ext): (ccshared,opt) = sysconfig.get_config_vars('CCSHARED','OPT') args['compiler_so'] = compiler + ' ' + opt + ' ' + ccshared if linker_so is not None: - args['linker_so'] = linker_so + ' -shared' + if platform == 'darwin1': + args['linker_so'] = linker_so + else: + args['linker_so'] = linker_so + ' -shared' self.compiler.set_executables(**args) build_ext.build_extensions(self) |