summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6de7aae..e717411 100644
--- a/setup.py
+++ b/setup.py
@@ -141,7 +141,10 @@ class PyBuildExt(build_ext):
(ccshared,opt) = sysconfig.get_config_vars('CCSHARED','OPT')
args['compiler_so'] = compiler + ' ' + opt + ' ' + ccshared
if linker_so is not None:
- args['linker_so'] = linker_so + ' -shared'
+ if platform == 'darwin1':
+ args['linker_so'] = linker_so
+ else:
+ args['linker_so'] = linker_so + ' -shared'
self.compiler.set_executables(**args)
build_ext.build_extensions(self)