summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bad5130..03a5c20 100644
--- a/setup.py
+++ b/setup.py
@@ -302,7 +302,12 @@ class PyBuildExt(build_ext):
if have_unicode:
exts.append( Extension('unicodedata', ['unicodedata.c']) )
# access to ISO C locale support
- exts.append( Extension('_locale', ['_localemodule.c']) )
+ if platform in ['cygwin']:
+ locale_libs = ['intl']
+ else:
+ locale_libs = []
+ exts.append( Extension('_locale', ['_localemodule.c'],
+ libraries=locale_libs ) )
# Modules with some UNIX dependencies -- on by default:
# (If you have a really backward UNIX, select and socket may not be