summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3b3d097..6a05643 100644
--- a/setup.py
+++ b/setup.py
@@ -898,8 +898,11 @@ class PyBuildExt(build_ext):
blake2_deps.append('hashlib.h')
blake2_macros = []
- if not cross_compiling and os.uname().machine == "x86_64":
- # Every x86_64 machine has at least SSE2.
+ if (not cross_compiling and
+ os.uname().machine == "x86_64" and
+ sys.maxsize > 2**32):
+ # Every x86_64 machine has at least SSE2. Check for sys.maxsize
+ # in case that kernel is 64-bit but userspace is 32-bit.
blake2_macros.append(('BLAKE2_USE_SSE', '1'))
exts.append( Extension('_blake2',