summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0357a01..65a1cfa 100644
--- a/setup.py
+++ b/setup.py
@@ -2044,7 +2044,7 @@ class PyBuildExt(build_ext):
# Thomas Heller's _ctypes module
self.use_system_libffi = False
include_dirs = []
- extra_compile_args = []
+ extra_compile_args = ['-DPy_BUILD_CORE_MODULE']
extra_link_args = []
sources = ['_ctypes/_ctypes.c',
'_ctypes/callbacks.c',
@@ -2298,8 +2298,10 @@ class PyBuildExt(build_ext):
# It's harmless and the object code is tiny (40-50 KiB per module,
# only loaded when actually used).
self.add(Extension('_sha256', ['sha256module.c'],
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE'],
depends=['hashlib.h']))
self.add(Extension('_sha512', ['sha512module.c'],
+ extra_compile_args=['-DPy_BUILD_CORE_MODULE'],
depends=['hashlib.h']))
self.add(Extension('_md5', ['md5module.c'],
depends=['hashlib.h']))