summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7481dd7..9762b9a 100644
--- a/setup.py
+++ b/setup.py
@@ -328,7 +328,6 @@ class PyBuildExt(build_ext):
# Some modules that are normally always on:
exts.append( Extension('regex', ['regexmodule.c', 'regexpr.c']) )
- exts.append( Extension('_hotshot', ['_hotshot.c']) )
exts.append( Extension('_weakref', ['_weakref.c']) )
# array objects
@@ -363,6 +362,9 @@ class PyBuildExt(build_ext):
exts.append( Extension("functional", ["functionalmodule.c"]) )
# Python C API test module
exts.append( Extension('_testcapi', ['_testcapimodule.c']) )
+ # profilers (_lsprof is for cProfile.py)
+ exts.append( Extension('_hotshot', ['_hotshot.c']) )
+ exts.append( Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c']) )
# static Unicode character database
if have_unicode:
exts.append( Extension('unicodedata', ['unicodedata.c']) )