summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 7f34c32..cc423c5 100644
--- a/setup.py
+++ b/setup.py
@@ -604,7 +604,8 @@ class PyBuildExt(build_ext):
# available here. This Makefile variable is also what the install
# procedure triggers on.
frameworkdir = sysconfig.get_config_var('PYTHONFRAMEWORKDIR')
- exts.append( Extension('gestalt', ['gestaltmodule.c']) )
+ exts.append( Extension('gestalt', ['gestaltmodule.c'],
+ extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('MacOS', ['macosmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('icglue', ['icgluemodule.c'],
@@ -613,8 +614,10 @@ class PyBuildExt(build_ext):
['macfsmodule.c',
'../Python/getapplbycreator.c'],
extra_link_args=['-framework', 'Carbon']) )
- exts.append( Extension('_CF', ['cf/_CFmodule.c']) )
- exts.append( Extension('_Res', ['res/_Resmodule.c']) )
+ exts.append( Extension('_CF', ['cf/_CFmodule.c'],
+ extra_link_args=['-framework', 'CoreFoundation']) )
+ exts.append( Extension('_Res', ['res/_Resmodule.c'],
+ extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_Snd', ['snd/_Sndmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
if frameworkdir: