summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 59b2548..9e411cb 100644
--- a/setup.py
+++ b/setup.py
@@ -1605,6 +1605,8 @@ class PyBuildExt(build_ext):
# if --enable-loadable-sqlite-extensions configure option is used.
if '--enable-loadable-sqlite-extensions' not in sysconfig.get_config_var("CONFIG_ARGS"):
sqlite_defines.append(("SQLITE_OMIT_LOAD_EXTENSION", "1"))
+ elif MACOS and sqlite_incdir == os.path.join(MACOS_SDK_ROOT, "usr/include"):
+ raise DistutilsError("System version of SQLite does not support loadable extensions")
if MACOS:
# In every directory on the search path search for a dynamic