summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 10 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index df434d4..4f4b42d 100644
--- a/setup.py
+++ b/setup.py
@@ -33,8 +33,16 @@ except ImportError:
with warnings.catch_warnings():
# bpo-41282 (PEP 632) deprecated distutils but setup.py still uses it
- warnings.filterwarnings("ignore", "The distutils package is deprecated",
- DeprecationWarning)
+ warnings.filterwarnings(
+ "ignore",
+ "The distutils package is deprecated",
+ DeprecationWarning
+ )
+ warnings.filterwarnings(
+ "ignore",
+ "The distutils.sysconfig module is deprecated, use sysconfig instead",
+ DeprecationWarning
+ )
from distutils import log
from distutils.command.build_ext import build_ext