summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7ddef8b..e0c6686 100644
--- a/setup.py
+++ b/setup.py
@@ -702,6 +702,11 @@ class PyBuildExt(build_ext):
exts.append( Extension('zlib', ['zlibmodule.c'],
libraries = ['z']) )
+ # Gustavo Niemeyer's bz2 module.
+ if (self.compiler.find_library_file(lib_dirs, 'bz2')):
+ exts.append( Extension('bz2', ['bz2module.c'],
+ libraries = ['bz2']) )
+
# Interface to the Expat XML parser
#
# Expat was written by James Clark and is now maintained by a