summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3d527fd..00245b5 100644
--- a/setup.py
+++ b/setup.py
@@ -194,18 +194,21 @@ class PyBuildExt(build_ext):
for e, f, g in zip(lst[::3], lst[1::3], lst[2::3]):
print("%-*s %-*s %-*s" % (longest, e, longest, f,
longest, g))
- print()
if missing:
print()
print("Failed to find the necessary bits to build these modules:")
print_three_column(missing)
+ print("To find the necessary bits, look in setup.py in"
+ " detect_modules() for the module's name.")
+ print()
if self.failed:
failed = self.failed[:]
print()
print("Failed to build these modules:")
print_three_column(failed)
+ print()
def build_extension(self, ext):
@@ -299,7 +302,8 @@ class PyBuildExt(build_ext):
# strip out double-dashes first so that we don't end up with
# substituting "--Long" to "-Long" and thus lead to "ong" being
# used for a library directory.
- env_val = re.sub(r'(^|\s+)-(-|(?!%s))' % arg_name[1], '', env_val)
+ env_val = re.sub(r'(^|\s+)-(-|(?!%s))' % arg_name[1],
+ ' ', env_val)
parser = optparse.OptionParser()
# Make sure that allowing args interspersed with options is
# allowed