summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b1e1c1e..87673d1 100644
--- a/setup.py
+++ b/setup.py
@@ -728,7 +728,7 @@ class PyBuildExt(build_ext):
db_incdir.replace("include", 'lib64'),
db_incdir.replace("include", 'lib'),
]
- db_dirs_to_check = filter(os.path.isdir, db_dirs_to_check)
+ db_dirs_to_check = [x for x in db_dirs_to_check if os.path.isdir(x)]
# Look for a version specific db-X.Y before an ambiguoius dbX
# XXX should we -ever- look for a dbX name? Do any
@@ -1555,7 +1555,7 @@ def main():
description = "A high-level object-oriented programming language",
long_description = SUMMARY.strip(),
license = "PSF license",
- classifiers = filter(None, CLASSIFIERS.split("\n")),
+ classifiers = [x for x in CLASSIFIERS.split("\n") if x],
platforms = ["Many"],
# Build info