diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -1041,12 +1041,12 @@ class PyBuildExt(build_ext): if host_platform == 'darwin': sysroot = macosx_sdk_root() - for d in inc_dirs + sqlite_inc_paths: - f = os.path.join(d, "sqlite3.h") - + for d_ in inc_dirs + sqlite_inc_paths: + d = d_ if host_platform == 'darwin' and is_macosx_sdk_path(d): - f = os.path.join(sysroot, d[1:], "sqlite3.h") + d = os.path.join(sysroot, d[1:]) + f = os.path.join(d, "sqlite3.h") if os.path.exists(f): if sqlite_setup_debug: print("sqlite: found %s"%f) with open(f) as file: |